LES(http://www.rfxn.com/projects/linux-environment-security/), Linux sisteminizde kritik dizinlere gerekli CHMOD vb.. değerlerini vererek sunucu güvenliğini artıran bir araçtır. Kullandığınız sistemin güvenliğini nasıl sağlayacağınızdan emin değilseniz, bu aracı çalıştırarak en kritik güvenlik ayarlarının yapılmasını sağlayabilirsiniz.

Önemli Not: Bu araç, sisteminizde, özellikle cpanel-directadmin-plesk-lxadmin vb.. bir kontrol paneli kullanıyorsanız sorun çıkmasına yol açabilir. cPanel ile yaptığımız testlerde bir sorunla karşılaşmasak da, olası sorunlara karşı sorumluluk size aittir.

Kurulum:


cd /usr/local/src
wget http://www.r-fx.ca/downloads/les-current.tar.gz
tar -zxvf les-current.tar.gz
cd les-0.*
./install.sh
rm -Rf /usr/local/src/les*

Yapabileceğiniz işlemleri görüntüleme:


/usr/local/sbin/les


-da | --disable-all Disable all options
-ea | --enable-all Enable all options
-sb | --secure-bin Set root only execution of critical binaries
-sp | --secure-path Set root only traversal of critical paths
-sr | --secure-rpmpkg Set immutable on core rpm package binaries
-so | --secure-prof Set immutable on interactive login profiles
-sd | --secure-devel Set access to devel utils for group deva & root

Bütün güvenlik ayarlarını etkinleştirme:

/usr/local/sbin/les -ea